[FFmpeg-devel] [PATCH] lavfi: rename AVFilterCommand.command to "verb"
eclipse7 at gmx.net
Sun Sep 25 17:01:43 CEST 2011
Stefano Sabatini wrote:
> On date Saturday 2011-09-24 22:06:30 +0200, Michael Niedermayer encoded:
> > On Sat, Sep 24, 2011 at 09:52:08PM +0200, Alexander Strasser wrote:
> > > Michael Niedermayer wrote:
> > > > On Sat, Sep 24, 2011 at 03:04:55PM +0200, Stefano Sabatini wrote:
> > > > > This avoids the confusing recursive terminology
> > > > > (AVFilterCommand.command).
> > > >
> > > > "verb" sounds really odd to me in this context.
> > >
> > > Maybe "name" or "id" would fit. Though "id" probably sounds a bit
> > > too abstract.
> > "name" sounds good to me too
> I named it like after the *TP (SMTP, HTTP, RTSP, SIP, etc.) protocols
> family, where you can have requests (aka "commands") and answers (aka
> "responses" aka "replies"), which are characterized by their "verb"
> (aka "method").
I knew you stole it from there :) I am familiar with some of the
standards you quoted above. Therefore it was not that surprising to
me you came up with that term.
> "name" suggests more an "identifier" rather than something which
> specifies the semantics of the command.
This is somehow off with me. As I see it the word command already
implies imperative form of a verb. Therefore it is still a valid
question to ask for the name of the command. In the sense of we
named the command <x>. I don't think stressing grammar terms too
much is needed here.
Anyway I am fine with any consensus you will reach. So please do
not see my comments as objections!
More information about the ffmpeg-devel