[FFmpeg-devel] [PATCH] Revert "matroskadec: don't set codec timebase."

Dale Curtis dalecurtis at chromium.org
Sat Apr 14 02:10:49 CEST 2012

On Fri, Apr 13, 2012 at 5:39 AM, Michael Niedermayer <michaelni at gmx.at>wrote:

> On Thu, Apr 12, 2012 at 05:26:23PM -0700, dalecurtis at chromium.org wrote:
> > From: Dale Curtis <dalecurtis at chromium.org>
> >
> > This commit introduced a regression in the amount of upfront
> > data required to identify and parse a webm container.  Most
> > visible under constrained networks: http://goo.gl/isfLc
> Setting r_frame_rate to avg_frame_rate should fix this

Can you elaborate on this? To be more clear, the time regression is in
avformat_find_stream_info which occurs before either of those values are

After discussion on libav, I found that setting fps_probe_size = 0 resolves
the time regression in avformat_find_stream_info as well.

To note, the issue does not show up in master ffmpeg/libav though because
w/o Chrome's patch to add incremental parsing of matroska clusters
find_stream_info takes forever parsing the whole first cluster anyways.
Some numbers:

find_stream_info w/o incremental parsing and w/o default_duration: 21054ms
(inline with avplay/ffplay)
find_stream_info w/ incremental parsing and w/o default_duration: 6683ms
find_stream_info w/ incremental parsing and w/ default_duration: 1026ms

I'll work on getting the incremental parsing patch up soon. Unfortunately
there's a minor FATE breakage I need to track down first.

- dale

More information about the ffmpeg-devel mailing list