[FFmpeg-devel] [PATCH] WMA Lossless: reset channel residues between subframes

Michael Niedermayer michaelni at gmx.at
Sat Apr 14 16:54:28 CEST 2012

On Sat, Apr 14, 2012 at 04:25:50PM +0200, Jakub Stachowski wrote:
> W dniu 2012-04-12 12:14, Mashiat Sarker Shakkhar pisze:
> >On 4/12/2012 2:36 PM, Benjamin Larsson wrote:
> >>On 04/12/2012 12:24 AM, Jakub Stachowski wrote:
> >>>Hello
> >>>
> >>>Attached patch fixes bug #1055. It causes channel residues to be reset
> >>>to 0 if they are not decoded from bitstream (is_channel_coded==0).
> >>>Without the patch, residues from last decoded subframe would be used,
> >>>which causes bursts of random noise in silent part of some files.
> >>>I am not sure if channel residues should not be reset in case of raw
> >>>pcm tiles, however I don't have any test file for that.
> >>
> >>Sounds ok. But Mashiat should look at it also.
> >
> >I don't really have anything to add. According to Jakub it fixes a bug,
> >and looks intuitive.
> >
> I found a mistake actually - it always clears residues for both
> channels instead only for the one with is_channel_coded==0. I have
> not found any files where this bug manifests itself, but it would
> overwrite valid samples with zeros if only second channel is not
> coded.
> Fix for a fix attached.




Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

it is not once nor twice but times without number that the same ideas make
their appearance in the world. -- Aristotle
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120414/6dacfa1f/attachment.asc>

More information about the ffmpeg-devel mailing list