[FFmpeg-devel] [PATCH 0/2] VDA decoder for ffmpeg

Xidorn Quan quanxunzhen at gmail.com
Wed Aug 22 05:33:06 CEST 2012

On Wed, Aug 22, 2012 at 11:14 AM, Michael Niedermayer <michaelni at gmx.at>wrote:

> On Wed, Aug 22, 2012 at 09:43:27AM +0800, Xidorn Quan wrote:
> > On Wed, Aug 22, 2012 at 5:30 AM, Michael Niedermayer <michaelni at gmx.at
> >wrote:
> >
> > > how can these problems be reproduced? / where can i find h264 samples
> > > that show these problems ?
> > >
> >
> > Any H.264 video with bit depth other than 8bit will prevent
> > the origin H.264 decoder from invoking get_format.
> if you simply grep for get_format in h264.c you can see a switch()
> for the various depths, adding get_format() calls to all depths
> that VDA supports should be quite easy.

In fact, I have found that before I made the dicision. But I don't
think it is easy to add get_format for all branch since this might
affect many downstream code. I have no confidence to doing so.

> > My testing shows that VDA can decode video with 10bit bit depth
> > though it doesn't output completely correct pictures.
> what exactly is wrong on these pictures ? is VDA ignoring the depth
> and using 8bit buffers/references ?

I don't actually know what's wrong with it, and I would like to do
more research to figure out. The picture attached is comparision of
pictures decoded by VDA and H.264 software decoder.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: v2.png
Type: image/png
Size: 297896 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120822/f386deae/attachment.png>

More information about the ffmpeg-devel mailing list