[FFmpeg-devel] [PATCH] configure: explicitly define library capabilities

Alexander Strasser eclipse7 at gmx.net
Thu Dec 13 19:42:13 CET 2012

Hi Lou!

Lou Logan wrote:
> Also add "encoding" for libopus.
> ---
>  configure | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
> diff --git a/configure b/configure
> index 48bfed2..74143ad 100755
> --- a/configure
> +++ b/configure
> @@ -198,32 +198,32 @@ External library support:
>    --enable-libfdk-aac      enable AAC encoding via libfdk-aac [no]
>    --enable-libflite        enable flite (voice synthesis) support via libflite [no]
>    --enable-libfreetype     enable libfreetype [no]
> -  --enable-libgsm          enable GSM de/encoding via libgsm [no]
> +  --enable-libgsm          enable GSM decoding and encoding via libgsm [no]

  I think in theory one could actually use the contraction codec here. But I guess
your version is fine and more "grep-friendly" (which might be one of your reasons
to sent the patch in the first place). Would also be a good idea to add that to the
commit message body to justify why the change was done.

  So LGTM.



More information about the ffmpeg-devel mailing list