[FFmpeg-devel] nacl ffplay few failures

Symadept symadept at gmail.com
Fri Jul 13 03:39:24 CEST 2012

Hi Roger,
You are absolutely right. I am trying to develop a video player that uses
ffmpeg to demux and SDL to play the video. ffplay that comes with ffmpeg
does this job which I tried on desktop but with ffmpeg version some 1.x or

But the ffmpeg that is ported to naclports is version 0.5. I am facing some
issues for nacl-mounts that can feed the media files to ffplay as same as
local files. I am still fixing the issues related to that.

In my current scenario, I am getting few warnings/errors concerned to
ffplay that is shown in the console. I am not sure how much those are
relevant for version 0.5 and I just want to treat them as headsup for me as
I move ahead.

Please do add your comments or concerns on the same. Any sort of
information is highly appreciable.

Mustafa Shaik

On Thu, Jul 12, 2012 at 11:30 PM, Roger Pack <rogerdpack2 at gmail.com> wrote:

> > iam not sure what you are trying to do or what doesnt work but that
> > ffplay version is many years old, alot has changed and been improved
> > since then. Trying the latest from ffmpeg.org will maybe solve your
> > problem
> NaCl (chrome's native client) has an ffmpeg port (based on 0.5) as
> something of a "demo" NaCl application, that's why people keep
> hearkening back to it, I presume.  Maybe hopefully someday its patches
> can be brought upstream and it can be re-synchronized with today's
> latest.
> -r
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list