[FFmpeg-devel] [PATCH] lavd/oss: support for more than 2 channels

Reimar Döffinger Reimar.Doeffinger at gmx.de
Sun Jul 22 11:24:19 CEST 2012

On 20 Jul 2012, at 19:58, Paul B Mahol <onemda at gmail.com> wrote:
> On 7/20/12, Nicolas George <nicolas.george at normalesup.org> wrote:
>> Le tridi 3 thermidor, an CCXX, Paul B Mahol a ecrit :
>>> Currently ffmpeg does not play 5.1 using oss outdev correctly, I get only
>>> noise
>> Not surprising, considering the code.
>>> (even if I give -channels 2 argument, yet another bug to fix).
>> Do you mean -ac 2? -channels is for inputs.
>>> With my patch I get actual sound.
>> And I said: sound that looks correct but is not is sometimes worse that no
>> sound at all or sound that is obviously wrong.
>> At least add a warning.
>>>                    If you want to fix ordering (for which i have
>>> no interest nor way to test) go ahead.
>> What is the point of getting surround to work halfway? If you have no way
>> to
>> test, then you do not need it, or am I missing something?
> Yes, I have nor time nor motivation to discuss bikesheding with you
> (or anyone else).

Could you please drop the attitude?
He pointed out an actual bug (channels will play in the wrong order), do you seriously that bikeshed? Particularly since that bug means that the whole new feature you add is not working properly, not just some corner-case.
If the noise bothers you, just make it bail out when it's > 2 channels, then someone motivated to implement it properly can do that later.

More information about the ffmpeg-devel mailing list