[FFmpeg-devel] DVB Subtitles

JULIAN GARDNER joolzg at btinternet.com
Mon Jun 11 00:19:58 CEST 2012

----- Original Message -----
> From: compn <tempn at twmi.rr.com>
> To: ffmpeg-devel at ffmpeg.org
> Cc: 
> Sent: Monday, 11 June 2012, 0:09
> Subject: Re: [FFmpeg-devel] DVB Subtitles
> On Sun, 10 Jun 2012 13:12:11 +0100 (BST), JULIAN GARDNER wrote:
>> Just pulled a new build and started trying my test dvb subtitles streams and 
> NONE work, get loads of errors about DTS being wrong on the subtitle stream.
> please make sample and post command line to reproduce issue.
> ffmpeg can fix bugs when we have bug reports.
> quicker fixes, if you find which commit broke it :)
> -compn
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

its a simple fix, which i have already implemented, remove the code from ffmpeg.c that says you need to call dvbsubtitles twice with a "turn on" and a "turn off", implement EPOCHs in the encoder and finally what needs adding is a call, when the last subtitle timeout runs out, with a new EPOCH to the encoder with no subtitles in it.

I have checked the encoder and it looks like the work i did ages ago, did make it into the encoder, thanks.

But one piece of code is still needed and that is the "removal code" as described above.

Also where would i now add my "Hard subs", can i still cheat and add it into the pre_process_video_frame, or is there a better place to add the code?


More information about the ffmpeg-devel mailing list