[FFmpeg-devel] build failure on osx 10.5.8 ppc

Pavel Koshevoy pkoshevoy at gmail.com
Sun Oct 7 23:11:05 CEST 2012

On 10/7/12 3:03 PM, Michael Niedermayer wrote:
> On Sun, Oct 07, 2012 at 02:58:04PM -0600, Pavel Koshevoy wrote:
>> On 10/7/12 2:22 PM, Michael Niedermayer wrote:
>>> On Sun, Oct 07, 2012 at 01:55:17PM -0600, Pavel Koshevoy wrote:
>>>> On 10/7/12 1:44 PM, Michael Niedermayer wrote:
>>>> <snip>
>>>>> About how to solve this, can you benchmark your patch against simply
>>>>> reverting this ?
>>>> Is there some benchmarking facility for this, or can you recommend
>>>> how I should do this?
>>> START/STOP_TIMER but i do not know how well this works on ppc
>> OK, but I also need something to exercise that code path.  It
>> appears to be multi-channel audio related.  I have a sample file
>> that should work (wmv 5.1 channels flt samples).  How can I see the
>> timing results?  I am running this command:
>> ./ffmpeg_g -i /nfs/scratch/DataSets/Video/multiChannelAudio/5.1\ ch\
>> 48k\ Robotica.wmv -acodec flac /tmp/benchmark-unrolled.flac
> they should be printed to the terminal.
> to make sure that code executes at all try to put something like
> a av_assert0(0) there or derefer a null ptr or something

I added a NULL pointer de-reference and it didn't crash, so that tells 
me I am not exercising that code path.

Any other suggestions, or should we give up on the benchmark?  I need to 
go clean the house and then work on a patch for fontconfig :)


More information about the ffmpeg-devel mailing list