[FFmpeg-devel] build failure on osx 10.5.8 ppc

Michael Niedermayer michaelni at gmx.at
Mon Oct 8 01:58:13 CEST 2012

On Sun, Oct 07, 2012 at 05:44:47PM -0600, Pavel Koshevoy wrote:
> On 10/7/12 4:06 PM, Michael Niedermayer wrote:
> >On Sun, Oct 07, 2012 at 03:11:05PM -0600, Pavel Koshevoy wrote:
> <snip>
> >I added a NULL pointer de-reference and it didn't crash, so that
> >tells me I am not exercising that code path.
> >
> >Any other suggestions, or should we give up on the benchmark?  I
> >need to go clean the house and then work on a patch for fontconfig
> >:)
> >compress a mp3 of your choice to .m4a with ffmpeg and then
> >try to decompress it, it should excercise the code
> >or take aac/al04_44.mp4 from the fate suite as a random samplle that
> >should use the code
> I rebuilt ffmpeg as follows:
> /nfs/scratch/Developer/ffmpeg-git-src/configure
> --prefix=/Developer/ppc --enable-swscale --enable-avfilter
> --enable-libmp3lame --enable-libvorbis --enable-libopus
> --enable-libtheora --enable-libschroedinger --enable-libopenjpeg
> --enable-libmodplug --enable-libvpx --enable-libspeex
> --enable-shared --enable-pthreads --enable-gpl --enable-version3
> --enable-libopencore-amrnb --enable-libopencore-amrwb
> --enable-postproc --enable-libx264 --enable-libxvid
> --enable-runtime-cpudetect --extra-cflags=-I/opt/local/include
> --extra-ldflags='-headerpad_max_install_names -L/opt/local/lib'
> --disable-stripping --enable-debug=3 --disable-optimizations
> I loaded ffmpeg_g into gdb in emacs and set a breakpoint in
> float_to_int16_stride_altivec.  I converted an mp3 to an m4a (had to
> add -strict -2 to ffmpeg options, and it was really slow).  I then
> converted the output m4a back to mp3 -- the breakpoint (and the NULL
> pointer de-reference were never hit).  I tried with aac/al04_44.mp4
> from fate suite and that didn't hit float_to_int16_stride_altivec
> either.  Looking at the code, float_to_int16_stride_altivec is only
> called from float_to_int16_interleave_altivec if number of channels
> is greater than 2.
> I also tried converting the 5.1 ch WMV file to flac again, and that
> didn't enter this function either.  ffprobe says that WMV file has
> flt samples, so it would seem to be a perfect candidate for this
> test.

this is strange it hit the x86 function here
have you checked that the function pointer is set at all ?
and you can just try make fate with the null deref in there to check
if any test uses it

> BTW, Is there a way to turn off ANSI colors on ffmpegs
> pretty-printed output?  It's really annoying in emacs gdb mode (it
> doesn't interpret the color codes, just spams the buffer with them).


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Those who are too smart to engage in politics are punished by being
governed by those who are dumber. -- Plato 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20121008/37c3fbae/attachment.asc>

More information about the ffmpeg-devel mailing list