[FFmpeg-devel] Changing frame properties not supported error out of no where?

Joey Leone jo2jo at validusdata.com
Mon Oct 8 07:57:04 CEST 2012

I have a centos 5.8 setup that has been running a video encoding script and converting videos from a few different formats to .mp4

Out of no where (meaning no mods or changes to ffmpeg or the server, it was just encoding videos) i noticed all the videos outputted to .mp4 had audio but NO video.

Running the ffmpeg command the script executes manually showed me this error:

[buffer @ 0x135ee20] Changing frame properties on the fly is not supported.
    Last message repeated 1238 times

here is the command im running:

ffmpeg -i "/home/test3.flv" -acodec libfaac -ab 128k -vcodec libx264 -vpre lossless_medium -crf 24 -y -v 0 -bf 16 "/SQLrd10/test333.mp4"

and the output is above.

ive tried lots of different variations of the ffmpeg command (all using -vcodec libx264 ofcorse) and i tried lots of different input videos (videos from the past that 100% have converted properly as i still have the logs and the proper .mp4 output).

 I must use this version of ffmpeg as my developer complied it and tested the switched used when ffmpeg is called. (its been running great for about a year now, lots of videos, no problems at all, server has 324 days of uptime even.)

[root at server ~]# ffmpeg -i
ffmpeg version 0.8.5, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jun 26 2012 02:22:00 with gcc 4.1.2 20080704 (Red Hat 4.1.2-52)
  configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --enable-pic
  WARNING: library configuration mismatch
  avutil      configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
  avcodec     configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
  avformat    configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
  avdevice    configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
  avfilter    configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
  swscale     configuration: --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads --enable-libxvid --enable-libx264 --enable-libmp3lame --enable-libfaac --disable-ffserver --disable-ffplay --enable-shared --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
  libavutil    51.  9. 1 / 51. 54.100
  libavcodec   53.  7. 0 / 53. 42. 4
  libavformat  53.  4. 0 / 53. 24. 2
  libavdevice  53.  1. 1 / 53.  4. 0
  libavfilter   2. 23. 0 /  2. 77.100
  libswscale    2.  0. 0 /  2.  1.100
  libpostproc  51.  2. 0 / 51.  2. 0

Can anyone offer any help? i really dont understand how something like this could just break or become corrupt and i cant find any similar help on google

More information about the ffmpeg-devel mailing list