[FFmpeg-devel] evaluating the experimental status of ffv1 version 3

Peter B. pb at das-werkstatt.com
Mon Sep 24 06:52:19 CEST 2012

On 09/24/2012 05:37 AM, Michael Niedermayer wrote:
> should be fixed with the patchset i just posted
I've applied all 3 patches.
Looks good: I've ran the tests now on "bridge_close_cif" and the results
are correct.
Thank you very much! :)

> please run the full tests with that patchset applied to confirm they
> work. Also id like to include this fix in the release so its
> important this is done now and not in 2 days or like all the
> other tests 6 month after when they where
> needed. In the meantime i dont even remember what i needed them for
I've now re-started the full testset with the patched ffmpeg version.
I'll post the results ASAP. The last test-run took *very long* to
process on my machine, so I can't say when all files have been processed :(

> speaking of this, the latency of the testing done is far FAR very FAR
> to big.
> To be of _any_ use in developing ffv1 tests have to be finished in
> less than 24h after i ask for them to be done.
I'm really, really, really sorry for the incredible delay! :(
I've now got a deadline-free time window, in which I've scheduled ffv1.3
with top-priority, because it's already embarrassing how long I didn't
find the time to do the tests. I hope this will be better now.

As written above, the tests with all sub-SD material from Derf's
collection at xiph.org took very long the last time - more than 1 day,
running non-stop. I've started it on another, faster machine now, so I
hope it will be finished sooner.

I'll post results ASAP.


More information about the ffmpeg-devel mailing list