[FFmpeg-devel] [PATCH] web/download: remove note about 0.6 release deprecation

Carl Eugen Hoyos cehoyos at ag.or.at
Wed Jan 9 23:32:26 CET 2013

Stefano Sabatini <stefasab <at> gmail.com> writes:

> > > The note gives the wrong impression that 0.6 is 
> > > somehow special and is the only deprecated release.
> > 
> > It is special in the sense that it contains a large 
> > number of bugs that were not present in 0.5, these 
> > should be fixed in 0.7 which is meant to be binary 
> > compatible and contains many features not present 
> > in 0.6.
> How is this different from any version compared to 
> the previous/next one?

I believe above is not correct for any other release.

> (X contains many bugs which were not present in X-1,

This is not how it is (supposed to be) done since 0.7, 
and I have no (or not much) reason to believe that it 
wasn't done very differently since.
I still use 0.5 quite often for testing and while it is 
old and missing many features (and bugfixes) it works 
not too bad.
0.6 received many regression reports on roundup that 
were only fixed when 0.7 was released, I very strongly 
recommend not to use it (and we never received an 
incompatibility report).

Carl Eugen

PS: Allow me to add that I am neither claiming that 
releases since 0.7 were bug-free nor that 0.7 really 
has no incompatibilities, just that to the best of 
my knowledge all reported regressions in releases 
after 0.6 were fixed (this is definitely not true 
for 0.6) and no API breaks for 0.7 were reported.

More information about the ffmpeg-devel mailing list