[FFmpeg-devel] flag naming conventions?

"René J.V. Bertin" rjvbertin at gmail.com
Sat Mar 9 12:53:04 CET 2013

I'm working on including my highres timing functions in libavutil/*/timer.h . Given in how many files this header is included, and also to avoid introducing cross-library dependencies for a single global variable (to convert ticks/time units to seconds), I'd propose to use a flag/switch to activate the additional code. When defined before including libavutil/timing.h my timer functions will be available, if not (the default), nothing will change w.r.t. the current situation.

Is there a naming convention for such flags/switches? I've named it AVUTIL_HIGHRES_TIMERS_REQUIRED for now.


More information about the ffmpeg-devel mailing list