[FFmpeg-devel] [RFC] Change av_get_channel_layout() syntax
stefasab at gmail.com
Mon Oct 7 11:57:24 CEST 2013
On date Friday 2013-10-04 17:11:28 +0200, wm4 encoded:
> On Fri, 4 Oct 2013 17:05:38 +0200
> Stefano Sabatini <stefasab at gmail.com> wrote:
> > On date Friday 2013-10-04 12:29:48 +0200, Stefano Sabatini encoded:
> > Untested attempt in attachment - also delievering a notable example of
> > backward-compatibility stunt.
> Why not add a separate function, instead of ifdef hell?
> (If you do add a separate function, make sure to clearly mark the
> preferred one to reduce confusion.)
Because I consider a separate av_get_channel_layout2() overkill, and
confusing since the difference with the new variant is really
minimal. I'll do only if people insist.
FFmpeg = Fascinating Free Monstrous Perennial Esoteric Genius
More information about the ffmpeg-devel