[FFmpeg-devel] [PATCH][GSoC] dshow add support for saving and loading of capture devices

Máté Sebők smfinc.org at gmail.com
Wed Apr 22 12:47:59 CEST 2015


Indeed, sorry i've forgotten to change the Eclipse' EOL to unix-- now fixed.

Error handler fixed.

Parameter names changed to audio(/video)_device_load(/save) as I think the
to_file and from_file is evident and is specified in the help.

About the "fake" input:  by loading a device filter from file, in the
dshow_open_device() it loads the device object from file instead of
searching it by name. So as long as the dshow_open_device() get called it
will load the device -- however to get called it is required to have a not
NULL input name .. aka any fake text would do the trick (eg: -i video=" " )
If you have better suggestion for the description, please tell me.

Here is the fixed patch.

Regards,
Máté

On Tue, Apr 21, 2015 at 9:38 PM, Roger Pack <rogerdpack2 at gmail.com> wrote:

> OK some verbiage nits:
>
>
> + at item capture_audio_device_load
> I'd suggest naming it it audio_device_load_from_filename instead.
> Similar for video.
>
> +Load an audio capture filter device from file instead of searching
> +it by name. It c, if the filter
> +supports the serialization of its properties to.
> +To use this an audio capture source has to be specified, but it can
> +be anything even fake one.
>
> "It may load"
>
> I'd probably say "even a fake one, but we recommend just specifying
> the name of the desired device."
>
> +If a file with the same name existed before it will be overwritten.
>
> suggest:
>
> If a file with the same name exists it will be overwritten.
>
> + at item capture_audio_device_save
> suggest rename to audio_device_to_filename, similar for video.
>
> Somehow this diff changed all the line endings so it appears as if the
> entire file has changed.  You can use "dos2unix" command to convert
> them back then do the diff again, so we can see what really changed.
>
> +        if (file_stream)
> +            IStream_Release(file_stream);
>
> I'd prefer to only have this only "once" which means either putting it
> in the error:
> section
> or creating your own error section "error1:" and on failure say "goto
> error1" or the like.
>
> GL!
>
> On 4/21/15, Máté Sebők <smfinc.org at gmail.com> wrote:
> > This patch allows for saving and loading of audio and video capture
> filter
> > devices (and in some cases its parameters) .
> > (similar to IPersistStream, but with the cleaner OleSaveToStream and
> > OleLoadFromStream methods)
> >
> > Regards,
> > Máté
> >
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-dshow-add-capture-device-save-and-load.patch
Type: application/octet-stream
Size: 8955 bytes
Desc: not available
URL: <https://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20150422/54135268/attachment.obj>


More information about the ffmpeg-devel mailing list