[FFmpeg-devel] [PATCH] vp9: add fullpel (avg) SIMD for 10/12bpp.

Ronald S. Bultje rsbultje at gmail.com
Wed Sep 16 13:24:39 CEST 2015


Hi,

On Tue, Sep 15, 2015 at 9:38 PM, James Almer <jamrial at gmail.com> wrote:

> On 9/15/2015 9:24 PM, Ronald S. Bultje wrote:
> > ---
> >  libavcodec/x86/vp9dsp_init_16bpp.c | 42
> ++++++++++++++++++++++++++++++--------
>
> Why not just add all this to vp9dsp_init.c and selectively initialize
> everything by checking the existing bpp argument in ff_vp9dsp_init_x86()?
> If you think you wont be able to reuse the existing macros in vp9dsp_init.c
> then i guess a new file would indeed be better to avoid bloat.
>
> Alternatively, macros that can be shared could be moved to a header and
> then used by both init files (like fpel_func and init_fpel).
>

Hm, yes, the macros for func decl should be shared, I'll re-do that part.

The init (func assignments) won't have anything shared, which is why I
thought it'd be useful to put it in separate files.

>  libavcodec/x86/vp9mc.asm           | 24 ++++++++++++++++++++++
> >  2 files changed, 58 insertions(+), 8 deletions(-)
> >
> > diff --git a/libavcodec/x86/vp9dsp_init_16bpp.c
> b/libavcodec/x86/vp9dsp_init_16bpp.c
> > index 3319012..25a7b2a 100644
> > --- a/libavcodec/x86/vp9dsp_init_16bpp.c
> > +++ b/libavcodec/x86/vp9dsp_init_16bpp.c
> > @@ -36,14 +36,22 @@ void ff_vp9_##avg##sz##_##opt(uint8_t *dst,
> ptrdiff_t dst_stride, \
>
> The naming scheme for other dsp functions in libavcodec is more like
> ff_codec_function_size_{8,10,12}_cpuflag(). Not too important for these as
> most are shared between all bpps, but for other functions it may be a good
> idea to rename the 8bit functions to follow the above naming scheme in
> preparation for the new 10/12bits ones.


I'll do that for avg, yes.

Thanks,
Ronald


More information about the ffmpeg-devel mailing list