[FFmpeg-devel] snapshots differ from git clone

Michael Niedermayer michael at niedermayer.cc
Wed Aug 3 00:11:34 EEST 2016

On Tue, Aug 02, 2016 at 10:54:15PM +0200, Jan Ehrhardt wrote:
> I have a script that cross-compiles ffmpeg on Ubuntu for Windows.
> Because it is faster to download a snapshot and extract it than
> doing a git clone the script uses
> http://ffmpeg.org/releases/ffmpeg-snapshot-git.tar.bz2
> Recently I ran into unresolved externals in x86/dirac_dwt_init.c/o.
> Details below. A clumsy workaround:
> $ rm -f libavcodec/x86/dirac*
> $ git stash
> The problem seems to be that the snapshots differ from a git clone
> and for instance contain >50 untracked files, amongst which:
>     libavcodec/x86/dirac_dwt.c
>     libavcodec/x86/dirac_dwt.h
>     libavcodec/x86/diracdsp_mmx.c
>     libavcodec/x86/diracdsp_mmx.h
>     libavcodec/x86/diracdsp_yasm.asm
>     libavcodec/x86/dwt_yasm.asm
>     libavcodec/x86/vc1dsp.asm
> A git clone has only these files:
>     libavcodec/x86/diracdsp.asm
>     libavcodec/x86/diracdsp_init.c
>     libavcodec/x86/dirac_dwt.asm
>     libavcodec/x86/dirac_dwt_init.c
> Question: why are the snapshots different from a git clone?

some stale files in the directory used to build the snapshot
ive fixed it earlier today
this should not reoccur

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Into a blind darkness they enter who follow after the Ignorance,
they as if into a greater darkness enter who devote themselves
to the Knowledge alone. -- Isha Upanishad
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20160802/acf8db95/attachment.sig>

More information about the ffmpeg-devel mailing list