[FFmpeg-devel] lavfi: introduce a new way of designing filters
george at nsup.org
Sun Dec 25 12:34:16 EET 2016
Le quintidi 5 nivôse, an CCXXV, Michael Niedermayer a écrit :
> after one quick pass looking through this i have mainly one request
> please seperate functions intended to be used by filters from functions
> intended to be used by the core. Maybe by using 2 seperate headers.
I had started to do that with the name of the functions:
The ff_link_* functions are meant to be used by filters. Now, I realize
I would like to rename them ff_inlink_* for the ones in this patch
series, that are used by the filters on their input links, and call
ff_outlink_* the ones for their output links.
The *_to_filter functions are the implementation of the default activate
callback, i.e. the callback that wraps the current filter_frame /
request_frame callbacks. This is not entirely consistent, I should
probably make a few cosmetic patches to rename them and group them.
I suppose you have no objection to having functions meant for filters
used by the core too if they fit the need exactly?
Do you have a suggested name for a separate header?
> People writing filters need to know which functions they can use and
> which they dont need to know of
As for that, I also intend to rewrite most of doc/filter_design.txt once
I have a reasonably clear view of the final shape, i.e. when at least a
few filters are written in the new design. A lot of it is long obsolete
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 833 bytes
Desc: Digital signature
More information about the ffmpeg-devel