[FFmpeg-devel] [PATCH] libavcodec/mmaldec.c: add interlaced_frame and format struct to AVFrame for deinterlacing

Moritz Barsnick barsnick at gmx.net
Sun Jul 3 18:05:43 CEST 2016


On Sun, Jul 03, 2016 at 17:20:41 +0200, Jens Ziller wrote:
> Am Samstag, den 02.07.2016, 17:54 +0200 schrieb Moritz Barsnick:
> > On Sun, Jun 26, 2016 at 17:12:14 +0200, Jens Ziller wrote:
> > > 
> > > +        ctx->interlaced_frame = !(interlace_type.eMode == MMAL_InterlaceProgressive);
> > What's wrong with using the "!=" operator instead?
> 
> "!=" is a comparing. "= !()" assign with a negate. Here is "= !()" needed.

I meant the comparison, not the assignment, so replacing:
  ctx->interlaced_frame = !(interlace_type.eMode == MMAL_InterlaceProgressive)
with
  ctx->interlaced_frame = (interlace_type.eMode != MMAL_InterlaceProgressive)

The former is rather ... convoluted.
(Brackets optional, but probably better for readability.)

Moritz


More information about the ffmpeg-devel mailing list