[FFmpeg-devel] [PATCH v2] libavfilter/vf_blackdetect.c

Jonathan Baecker jonbae77 at gmail.com
Sun Dec 10 15:12:00 EET 2017

Am 10.12.2017 um 13:48 schrieb Carl Eugen Hoyos:
> 2017-12-09 19:28 GMT+01:00 Jonathan Baecker <jonbae77 at gmail.com>:
>> -static void check_black_end(AVFilterContext *ctx)
>> +static void check_black(AVFilterContext *ctx)
> Why do you rename this function?
I rename them because before the function only got called, if the last 
black frame passes. Now the function get called already when the first 
black frame comes. So for me are more generic name is more logic. But if 
you want I can change them back!
> Please remove the superfluous brackets in the "if()"
> you change.
I did not touch them, but yes I will remove them! Thanks for command!

More information about the ffmpeg-devel mailing list