[FFmpeg-devel] [PATCH] frame: Simplify the video allocation

James Almer jamrial at gmail.com
Mon Sep 3 16:29:13 EEST 2018


On 9/3/2018 5:17 AM, Michael Niedermayer wrote:
> On Sun, Sep 02, 2018 at 09:34:23PM -0300, James Almer wrote:
>> From: Luca Barbato <lu_zero at gentoo.org>
>>
>> Merged-by: James Almer <jamrial at gmail.com>
>> ---
>> This is the next merge in the queue. It's a critical part of the AVFrame API,
>> so even if FATE passes I'd rather have others look at it and test in case
>> something breaks.
>>
>> The only difference compared to the libav commit is the "32 - 1" padding per
>> plane when allocating the buffer, which was only in our tree.
> 
> why is the STRIDE_ALIGN (which is a thing in units of bytes along the
> horizontal axis) added to padded_height which is vertical axis ?
> This is not done prior to the change

The only way to keep this padding we currently have in the tree applied
to the buffer allocation for each plane like it was before the change
(Except it'll now be one continuous buffer instead of one per plane) is
by passing it alongside the height parameter to
av_image_fill_pointers(). The result is essentially the same.

Do you want me to change the name of the variable, or remove it and pass
32 - 1 to both av_image_fill_pointers() calls directly? Removing the
padding will probably just make whatever overreads prompted its addition
to resurface.
Alternatively, i can just no-op this merge and move on.

> 
> Also if this changes how buffers are structured or sized it requires a more
> detailed commit message than "frame: Simplify the video allocation"

Suggestion welcome, but it would be added to the merge commit message.

> 
> thanks
> 
> [...]
> 
> 
> 
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
> 



More information about the ffmpeg-devel mailing list