[FFmpeg-devel] [PATCH 5/5] lavfi: addroi filter

Moritz Barsnick barsnick at gmx.net
Thu Feb 28 15:53:03 EET 2019

On Thu, Feb 28, 2019 at 01:18:06 +0000, Mark Thompson wrote:
> > Can ROIs not also be defined as x, y, w, h?
> Sure, it would be easy to change if people prefer that.

It was just my personal observation (and preference)

> This was chosen pretty much entirely because it matches the structure
> definition

Oh yeah, I thought so.

> Would "iw"/"ih" be better, or would that just be more confusing?

I'm not sure, I was just thinking consistence with other filters. You
do have an "outgoing" size, that's the size of the ROI. So perhaps
iw/ih also applies.

Just my €0,02,

More information about the ffmpeg-devel mailing list