[FFmpeg-trac] #429(undetermined:open): ffmpeg is killed by kernel (out of Memmry)

FFmpeg trac at avcodec.org
Tue Sep 6 01:09:20 CEST 2011

#429: ffmpeg is killed by kernel (out of Memmry)
             Reporter:  mus          |                    Owner:  michael
                 Type:  defect       |                   Status:  open
             Priority:  normal       |                Component:
              Version:  unspecified  |  undetermined
             Keywords:  memory x264  |               Resolution:
  killed kernel                      |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |

Comment (by mus):


 I uploaded the subtitle file only (within a MKV container). I tried to
 split the whole file in <100MB parts, but then it is not reproducible
 because ffmpeg is done too fast. You should be able to reproduce it if you
 merge the subtitle with a big video file. I tried it myself, I merged the
 video track of another file with the subtitle and could reproduce it with
 the resulting file (which then only contains one video and one subtitle

 First merge it:
 mkvmerge -o merged.mkv -A -S input.mkv subsample.mkv

 Then start ffmpeg, which should be killed after a few minutes:
 ffmpeg -i merged.mkv -c copy out.mkv

 Another interesting thing: Doing the merging with ffmpeg will not cause
 the problem:

 ffmpeg -i input.mkv -i subsample.mkv -c copy -map 0:v:0 -map 1:s:0

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/429#comment:9>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list