[FFmpeg-trac] #504(undetermined:new): Fixing av_seek_frame

FFmpeg trac at avcodec.org
Mon Sep 26 23:58:33 CEST 2011

#504: Fixing av_seek_frame
             Reporter:  DonMoir      |                    Owner:
                 Type:  defect       |                   Status:  new
             Priority:  normal       |                Component:
              Version:  unspecified  |  undetermined
             Keywords:               |               Resolution:
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  0

Comment (by DonMoir):

 A lot of the seek errors I am seeing are with MPEG1 files. Not all of them
 fail though. I get some failures with MPEG2 as well. I am still looking
 into this. Most of the other formats I have tried work pretty good but I
 have this CODEC_ID_H264 case that fails. (AspectRatioHB.mpg). This
 particular file has 1 keyframe in the first frame and it is marked as
 such. The timestamp for this frame is negative which might have something
 to do with the failure but I don't know. Any attempt to seek directly to
 this first frame will fail. I have tried serveral different ways to seek
 to the frame but it always ends up with incorrect results. Other ways
 might be avio_seek and update the timestamp etc. Like the seek may return
 -1 or if I rearrange things seek returns success but then on decode I
 might get a gray frame or similiar. The rest of the H264 files I have work

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/504#comment:1>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list