[FFmpeg-trac] #1938(build system:open): Provide c99wrap.exe and c99conv.exe

FFmpeg trac at avcodec.org
Fri Dec 7 17:39:05 CET 2012

#1938: Provide c99wrap.exe and c99conv.exe
             Reporter:  theateist    |                    Owner:
                 Type:  enhancement  |                   Status:  open
             Priority:  wish         |                Component:  build
              Version:  git-master   |  system
             Keywords:  msvc         |               Resolution:
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  1
Changes (by rafi):

 * component:  documentation => build system


 Replying to [comment:9 theateist]:
 > Replying to [comment:8 cehoyos]:
 > > Use these executables until we can provide them:
 > > https://github.com/libav/c99-to-c89/downloads
 > 1 - I placed makedef, c99wrap.exe, c99conv.exe, and yasm.exe to "c:\ex"
 and added "c:\ex" to PATH
 > 2 - I downloaded latest ffmpeg source to "c:\ff_src" and placed
 inttypes.h to "c:\ff_src"
 > 3 - I ran msys.bat from the Visual Studio command prompt.
 > 4 - ran ./configure --toolchain=msvc
 > 5 - ran make
 > I expected that after "make" I'll get compiled ffmpeg in VS manner and
 namely lib,pdb,exe files, but I get .a,.d,.o files instead. It seems that
 it was compiled by gcc and not cl!
 > What could happened?
 > Thank you


  i followed the steps as described above. but when i run the msys.bat
 which is located in
  my directory : C:\MinGW\msys\1.0
  it just enter into some command shell & thats it.
  when i edit the msys.bat i see it is shown in my notpad with no CRLF but
 as long line.
  can you help ?

   thanks rafi

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/1938#comment:19>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list