[FFmpeg-trac] #2066(FFmpeg:closed): Facing problem related to directpred (Please find attached screen shot)

FFmpeg trac at avcodec.org
Wed Dec 26 12:29:33 CET 2012

#2066: Facing problem related to directpred (Please find attached screen shot)
             Reporter:  indecomm     |                    Owner:
                 Type:  defect       |                   Status:  closed
             Priority:  normal       |                Component:  FFmpeg
              Version:  unspecified  |               Resolution:  invalid
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |

Comment (by indecomm):


 Sorry for providing very brief description on the issue.

 Here is the complete update on the issue,

 Basically we are trying to convert a multimedia file (of any format) to
 .mp4 format using some third party presets.
 Attached here with filename (test.ffpreset).

 We have imported this preset into winff tool and tried to convert a
 multimedia file(.flv) to .mp4 file. The preset

 selected in the tool had the value as "-f mp4 -acodec vorbis -aq 30 -ab
 128k -ac 2 -ar 24000 -vcodec libx264 -

 fpre test.ffpreset -b 330k -s 640x360 -vf pad=iw:ih+2*60:0:60 -strict
 experimental -threads 0"

 Conversion was unsuccessful with below error
 "Unrecognized option 'directpred'
 libx264-ingenico.ffpreset: Invalid option or argument: 'directpred=3
 ', parsed as 'directpred' = '3'"

 Later we tried by changing "directpred" to "direct-pred", again it was
 unsuccessful with below error
 Please use -b:a or -b:v, -b is ambiguous
 [NULL @ 032a5f60] [Eval @ 0022e6fc] Undefined constant or missing '(' in

 [NULL @ 032a5f60] Unable to parse option value "mixed-refs-dct8x8
 [NULL @ 032a5f60] Error setting option flags2 to value -mixed-refs-
 Output #0, mp4, to 'C:\Users\Kamalesh.Kumar\Desktop\desparado.mp4':
     WMFSDKVersion   : 12.0.7601.17514
     WMFSDKNeeded    :
     IsVBR           : 0
     title           : Facebook
     Stream #0:0: Video: none, yuv420p, 640x360, q=-1--1, 90k tbn, 29.97
     Stream #0:1: Audio: none, 24000 Hz, stereo, fltp, 128 kb/s
 Stream mapping:
   Stream #0:1 -> #0:0 (wmv3 -> libx264)
   Stream #0:0 -> #0:1 (wmav2 -> vorbis)
 Error while opening encoder for output stream #0:0 - maybe incorrect
 such as bit_rate, rate, width or height

 Could you please suggest us a solution on what preset values should be
 used for above mentioned configurations.

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/2066#comment:4>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list