[FFmpeg-trac] #2823(avcodec:closed): Building ffmpeg failed

FFmpeg trac at avcodec.org
Sat Aug 3 09:08:45 CEST 2013

#2823: Building ffmpeg failed
             Reporter:  pradeepvr   |                    Owner:
                 Type:  defect      |                   Status:  closed
             Priority:  critical    |                Component:  avcodec
              Version:  git-master  |               Resolution:  fixed
             Keywords:  regression  |               Blocked By:
             Blocking:              |  Reproduced by developer:  0
Analyzed by developer:  0           |

Comment (by pradeepvr):

 Replying to [comment:6 cehoyos]:
 > Please provide a little more information: Which version are you trying
 to compile, what is your configure line, how does it fail?

 '''When I run version.sh file in ffmpeg root directory it shows
 "N-55069-g6df20d0", I think this is the version you are mentioning

 I don't get what "configure line" means, am trying to build ffmpeg on
 ubuntu 10.04.

 When I run make command(after configure) I get below error:

 libavcodec/avpacket.c:262: warning: ‘destruct’ is deprecated (declared at
 libavcodec/avpacket.c:263: warning: ‘destruct’ is deprecated (declared at
 libavcodec/avpacket.c:264: warning: ‘destruct’ is deprecated (declared at
 libavcodec/avpacket.c: In function ‘av_packet_merge_side_data’:
 libavcodec/avpacket.c:336: warning: ‘destruct’ is deprecated (declared at
 CC libavcodec/avpicture.o
 CC libavcodec/avrndec.o
 CC libavcodec/avs.o
 CC libavcodec/avuidec.o
 CC libavcodec/avuienc.o
 CC libavcodec/bethsoftvideo.o
 CC libavcodec/bfi.o
 CC libavcodec/bgmc.o
 CC libavcodec/bink.o
 CC libavcodec/binkaudio.o
 CC libavcodec/binkdsp.o
 CC libavcodec/bintext.o
 CC libavcodec/bitstream.o
 libavcodec/bitstream.c: In function ‘ff_init_vlc_sparse’:
 libavcodec/bitstream.c:348: error: unable to find a register to spill in
 class ‘AREG’
 libavcodec/bitstream.c:348: error: this is the insn:
 (insn 556 555 557 94 ./libavutil/atomic_gcc.h:57 (parallel [
 (set (reg:SI 1 dx [orig:82 D.9034 ] [82])
 (mem/v:SI (plus:SI (reg/v/f:SI 99 [ vlc ])
 (const_int 16 [0x10])) [-1 S4 A32]))
 (set (mem/v:SI (plus:SI (reg/v/f:SI 99 [ vlc ])
 (const_int 16 [0x10])) [-1 S4 A32])
 (unspec_volatile:SI [
 (mem/v:SI (plus:SI (reg/v/f:SI 99 [ vlc ])
 (const_int 16 [0x10])) [-1 S4 A32])
 (reg/v/f:SI 99 [ vlc ])
 (reg/f:SI 1 dx [196])
 ] 10))
 (clobber (reg:CC 17 flags))
 ]) 2003 {*sync_compare_and_swapsi} (expr_list:REG_DEAD (reg/f:SI 1 dx
 (expr_list:REG_UNUSED (reg:CC 17 flags)
 libavcodec/bitstream.c:348: confused by earlier errors, bailing out
 Preprocessed source stored into /tmp/ccQuH6Sm.out file, please attach this
 to your bugreport.
 make: * [libavcodec/bitstream.o] Error 1

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/2823#comment:7>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list