[FFmpeg-trac] #2918(undetermined:new): Transmuxing Facebook MP4s creates bad mpeg-ts stream

FFmpeg trac at avcodec.org
Fri Aug 30 20:03:21 CEST 2013

#2918: Transmuxing Facebook MP4s creates bad mpeg-ts stream
             Reporter:  nealzebub    |                    Owner:
                 Type:  defect       |                   Status:  new
             Priority:  normal       |                Component:
              Version:  unspecified  |  undetermined
             Keywords:               |               Resolution:
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  0

Comment (by nealzebub):

 Replying to [comment:1 cehoyos]:
 > Replying to [ticket:2918 nealzebub]:
 > > Attempting to transmux an MP4 file downloaded from Facebook to mpeg-ts
 or HLS stream results in an an invalid stream.  By invalid, I mean an
 mpeg-ts file or pipe stream is produced that FFmpeg itself cannot use.
 > I tried to remux the mp4 file you attached, and the output stream plays
 fine here with ffplay and can be transcoded with ffmpeg. Could you explain
 (again) what is wrong with the output file?

 Now that you have that "out.ts", attempt to remux it to HLS(mpeg-ts)
 segments, like what I tried.  Then you'll see the problem.

 ffmpeg -i out.ts -map 0 -sn -codec copy -bsf:v h264_mp4toannexb -f
 ssegment -segment_format mpegts -initial_offset 10 segmentName_%04d.ts

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/2918#comment:2>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list