[FFmpeg-trac] #1398(avformat:open): remuxed DTS audio won't play on hardware devices

FFmpeg trac at avcodec.org
Fri Apr 25 05:02:20 CEST 2014

#1398: remuxed DTS audio won't play on hardware devices
             Reporter:  patters     |                    Owner:
                 Type:  defect      |                   Status:  open
             Priority:  normal      |                Component:  avformat
              Version:  git-master  |               Resolution:
             Keywords:  dca mpegts  |               Blocked By:
             Blocking:              |  Reproduced by developer:  0
Analyzed by developer:  0           |

Comment (by goodthanks):

 Replying to [comment:32 cehoyos]:
 > Do you have git installed?
 > If yes, update your checkout with {{{git pull}}} make the necessary
 changes to libavformat/mpegts.h and libavformat/mpegtsenc.c, then commit
 them with {{{git commit libavformat}}} and produce a patch file with
 {{{git format-patch HEAD^}}} which you can send to the mailing list.

 Ok I have done all that but im stuck at {{{git send-email}}}. I have
 everything set correctly but it errors with
 Need MIME::Base64 and Authen::SASL
 cpan Authen::SASL - worked
 cpan MIME::Base64 - failed so I did cpan MIME::Base64::Perl which worked.

 Didn't make any difference, I still get the following error - Need
 MIME::Base64 and Authen::SASL

 Keep in mind 2 days ago I had never heard of Git or Mingw so I've probably
 set something up wrong.

 Can I just send the patch file using my mail client (Thunderbird) instead
 of git or does {{{git send-email}} do some necessary change to the patch
 file before sending?

Ticket URL: <https://trac.ffmpeg.org/ticket/1398#comment:33>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list