[FFmpeg-trac] #3902(avformat:new): FFmpeg MD5 output different with same data #3

FFmpeg trac at avcodec.org
Sat Aug 30 14:21:36 CEST 2014

#3902: FFmpeg MD5 output different with same data #3
             Reporter:               |                    Owner:
  ahthovaikied                       |                   Status:  new
                 Type:  defect       |                Component:  avformat
             Priority:  normal       |               Resolution:
              Version:  git-master   |               Blocked By:
             Keywords:  md5 mpeg2    |  Reproduced by developer:  0
  ac3 mkv                            |
             Blocking:               |
Analyzed by developer:  0            |

Comment (by ahthovaikied):

 Replying to [comment:17 cehoyos]:
 > Then please repeat your findings in one sentence, this is a long ticket
 (and it isn't clear to anybody what you are trying to prove).
 I understand you have limited available time, and appreciate you taking
 some to help me, but you have asked the same question several times
 without even reading my answer...
 This is not a simple problem, I can not make it one.

 Anyway here is the shortest summary I can make:
 * I have some files (MPEG2 video + AC3 audio), for which the command:
 {{{ffmpeg -i input.mkv -map v -map a -c copy -f md5 -}}} returns different
 MD5 between 2 FFmpeg builds of the same version, with the same configure
 options on 2 different machines
 * A short file to reproduce the problem has been uploaded on FFmpeg's FTP
 * The problem can only be seen when selecting video '''and''' audio
 streams, with only video or only audio, the MD5 matches
 * {{{-thread 1}}} or build with {{{--disable-pthreads}}} does not change
 * After trying to use the same exact binary on both machines, I found out
 the difference is introduced by the fact thah one of the build is linking
 against vdpau and vaapi
 * When building with {{{--disable-vaapi --disable-vdpau}}}, the difference
 of MD5 is gone
 * When building with only {{{--disable-vaapi}}} or {{{--disable-vdpau}}},
 there is a difference of MD5
 * I tried going back to older FFmpeg release, and they produce the same
 MD5 with {{{--disable-vaapi --disable-vdpau}}} or without
 * I ran a git bisect, and the weird behavior started at commit
 * Building with {{{--disable-parser=hevc}}} does not eliminate the
 difference of MD5 for recent FFmpeg versions

Ticket URL: <https://trac.ffmpeg.org/ticket/3902#comment:20>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list