[FFmpeg-trac] #3649(avutil:new): Solaris Intel static libraries required AMD 3D NOW even though the CPU doesn't support

FFmpeg trac at avcodec.org
Mon Jun 2 02:21:17 CEST 2014

#3649: Solaris Intel static libraries required AMD 3D NOW even though the CPU
doesn't support
             Reporter:  bmitchel       |                    Owner:
                 Type:  defect         |                   Status:  new
             Priority:  minor          |                Component:  avutil
              Version:  2.2.1          |               Resolution:
             Keywords:  solaris intel  |               Blocked By:
             Blocking:                 |  Reproduced by developer:  0
Analyzed by developer:  0              |

Comment (by bmitchel):

 Replying to [comment:7 cehoyos]:
 > Please understand that there is nothing ''unstable'' about current git
 head, it is exactly as stable as a release branch (but contrary to a
 release branch, we support it also if you are not a distributor).

 I was not trying to imply it wasn't unstable.  Bad use of language there.

 > Why are you using {{{--extra-cflags="-fPIC"}}}?
 > Why not {{{--enable-pic}}} (or neither of them)?

 I'll use --enable-pic.  I started building this on SPARC Solaris, then
 Intel Solaris and Windows on much older versions so some of these things
 have stuck.

 > You should first take care about this important issue (that makes your
 binaries unusable and imo unsupported - at least I consider --disable-mmx
 a pure debug option).

 I will remove it.  Just the way again I've previously compiled.

 > This is so outdated that it has no relevance for your problem.

 Understood.  I know this has nothing to do with my issue, it was just the
 build instructions I've previously used and refined to a certain extent
 (mainly the configure).

 > (Generally, a line number would help, fortunately it is unneeded here.)
 > What does the following show?
 > {{{$ grep HAVE_EB config.h}}}

 barney(bradm) grep HAVE_EB config.h

 > Could you test forcing one of them to 0?
 > This should lead to a permanent fix.

 I tried changing HAVE_EBX_AVAILABLE to 0 also, and this still resulted in
 the same error:

 CC      libavfilter/vf_noise.o
 "vf_noise.c", [line_noise_avg_mmx]:ube: error: Cannot allocate register
 for argument '%5' in GASM Inlining
 cc: ube failed for libavfilter/vf_noise.c
 gmake: *** [libavfilter/vf_noise.o] Error 2

 There is no line number specified in the output for the error.

 > Please do us all a favor and also test gcc.

 Absolutely.  There is a much older version of gcc installed (3.4.3) which
 is stock standard installed for Solaris.  Any recommendations on a version
 you would suggest?  I'm not overly familiar with the gcc compiler.

Ticket URL: <https://trac.ffmpeg.org/ticket/3649#comment:8>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list