[FFmpeg-trac] #3649(avutil:new): Solaris Intel static libraries required AMD 3D NOW even though the CPU doesn't support

FFmpeg trac at avcodec.org
Mon Jun 2 08:44:53 CEST 2014

#3649: Solaris Intel static libraries required AMD 3D NOW even though the CPU
doesn't support
             Reporter:  bmitchel       |                    Owner:
                 Type:  defect         |                   Status:  new
             Priority:  minor          |                Component:  avutil
              Version:  2.2.1          |               Resolution:
             Keywords:  solaris intel  |               Blocked By:
             Blocking:                 |  Reproduced by developer:  0
Analyzed by developer:  0              |

Comment (by cehoyos):

 Replying to [comment:8 bmitchel]:
 > > Why are you using {{{--extra-cflags="-fPIC"}}}?
 > > Why not {{{--enable-pic}}} (or neither of them)?
 > I'll use --enable-pic.

 Why is --enable-pic needed? I believe it caused one of your problems and
 it would be good to understand the underlying problem better.

 > > You should first take care about this important issue (that makes your
 binaries unusable and imo unsupported - at least I consider --disable-mmx
 a pure debug option).
 > I will remove it.  Just the way again I've previously compiled.
 > > This is so outdated that it has no relevance for your problem.
 > Understood.  I know this has nothing to do with my issue, it was just
 the build instructions I've previously used and refined to a certain
 extent (mainly the configure).

 If {{{./configure && make}}} does not work, it would be great if you could
 report that.

 > > What does the following show?
 > > {{{$ grep HAVE_EB config.h}}}
 > barney(bradm) grep HAVE_EB config.h
 > > Could you test forcing one of them to 0?
 > > This should lead to a permanent fix.
 > I tried changing HAVE_EBX_AVAILABLE to 0 also, and this still resulted
 in the same error:
 > CC      libavfilter/vf_noise.o
 > "vf_noise.c", [line_noise_avg_mmx]:ube: error: Cannot allocate register
 for argument '%5' in GASM Inlining
 > cc: ube failed for libavfilter/vf_noise.c
 > gmake: *** [libavfilter/vf_noise.o] Error 2

 Sorry, I had forgotten: This was fixed a month ago, as said please test
 current FFmpeg git head.

 > > Please do us all a favor and also test gcc.
 > Absolutely.  There is a much older version of gcc installed (3.4.3)
 which is stock standard installed for Solaris.  Any recommendations on a
 version you would suggest?  I'm not overly familiar with the gcc compiler.

 gcc 3.4.3 is so outdated that it might be better to fix the issues with
 your current compiler, a suggested version would be gcc 4.8.3.

Ticket URL: <https://trac.ffmpeg.org/ticket/3649#comment:9>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list