[FFmpeg-trac] #3694(undetermined:new): When transcoding from FLAC to MP3 the Year tag gets lost in the resulting mp3 file

FFmpeg trac at avcodec.org
Wed Jun 4 17:41:27 CEST 2014

#3694: When transcoding from FLAC to MP3 the Year tag gets lost in the resulting
mp3 file
             Reporter:               |                    Owner:
  dslkjlskdjfllk                     |                   Status:  new
                 Type:  defect       |                Component:
             Priority:  normal       |  undetermined
              Version:  git-master   |               Resolution:
             Keywords:  flac mp3     |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |

Comment (by dslkjlskdjfllk):


 I do know there are different id tag versions, and I know for a fact that
 both winamp and mp3tag WILL read id tags v1 and id tag v2. In fact, in my
 example above, the title, artist, album and genre fields are properly
 filled for ID v2 (and readable both in winamp and mp3tag). It is the YEAR
 tag that is not filled.

 I tried ffmpeg -i "Bad Medicine.flac" -qscale:a 2 -write_id3v1 1 test.mp3
 and id tag v1 was correctly created, with the year field filled. But in
 the ID Tag v2.4, the year is missing.

 I tried ffmpeg -i "Bad Medicine.flac" -qscale:a 2 -id3v2_version 3
 test.mp3 and in that case, indeed the year tagt is correctly filled with
 "2010" - both in winamp and in mp3 tag.

 But, again, when I try ffmpeg -i "Bad Medicine.flac" -qscale:a 2 test.mp3,
 mp3tag (the latest version) tells me that this mp3 file has an ID3v2.4
 tag, it correctly gives me the title, artist, genre, track, album, but
 year is empty.

 When I mouse-over in windows, it tells me all those fields, as well as the
 "Release Date" to be 2010, but the YEAR tag doesn't show up. When I mouse-
 over the 2.3 version, the YEAR field is set to 2010, not the field RELEASE

 Could it be that there is a mix-up between RELEASE DATE and YEAR when
 building the id3v2.4 tag? It appears to be the case.

Ticket URL: <https://trac.ffmpeg.org/ticket/3694#comment:5>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list