[FFmpeg-trac] #3730(undetermined:reopened): libx265 ignores threads option.

FFmpeg trac at avcodec.org
Mon Jun 23 08:36:05 CEST 2014

#3730: libx265 ignores threads option.
             Reporter:  Danixu       |                    Owner:
                 Type:  defect       |                   Status:  reopened
             Priority:  normal       |                Component:
              Version:  git-master   |  undetermined
             Keywords:               |               Resolution:
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  0

Comment (by Danixu):

 With your command the program uses less CPU time, but continues using more
 than one thread (about 70%-85%). With threads 2 or 8 uses the same CPU.

 I've tried with MP4 instead hevc to use libx264, and works fine (just 50%
 and with threads 2 about 95%).

 Finally, the x264 problem is command line, because this works:

 % ffmpeg.exe -i in.mp4 -threads 1 -c:v libx264 out.mp4

 but with x265 still no working.


Ticket URL: <https://trac.ffmpeg.org/ticket/3730#comment:5>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list