[FFmpeg-trac] #3627(ffmpeg:new): How to fix build_android.sh: function: not found error?

FFmpeg trac at avcodec.org
Fri May 9 14:41:08 CEST 2014

#3627: How to fix  build_android.sh: function: not found error?
             Reporter:  vinoth       |                    Owner:
                 Type:  defect       |                   Status:  new
             Priority:  important    |                Component:  ffmpeg
              Version:  unspecified  |               Resolution:
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  1            |

Comment (by vinoth):

 Replying to [ticket:3627 vinoth]:
 > I'm trying to separate audio and video from video file. After searching
 on the internet I came to know it can be done using FFMPEG.
 > Now I need to build FFMPEG library file for my Android application using
 Ubuntu version 14.04 (64-bit) NDK R9 ffmpeg 2.2.2 while building it causes
 an error below line:
 > Logcat:
 > build_android.sh: 9: build_android.sh: function: not found.
 > kdir: cannot create directory ‘/usr/local/share/man/man3’: Permission
 > make: *** [install-man] Error 1
 > build_android.sh: 67: build_android.sh: build_one: not found
 > To fix that issue I searched on the internet and I got a solution.
 Either in ./build_android.sh or in ./configure you have an extra ^M. Open
 the files with vi and clean them from this garbage.
 > I've fixed it and tried by fixing some other solution also but remains
 the same.
 > How can I fix this?

Ticket URL: <https://trac.ffmpeg.org/ticket/3627#comment:1>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list