[FFmpeg-trac] #4037(undetermined:new): [Transcoding] Duration and frame number changed after transcoding

FFmpeg trac at avcodec.org
Mon Oct 20 11:47:15 CEST 2014

#4037: [Transcoding] Duration and frame number changed after transcoding
             Reporter:  hungnv       |                    Owner:
                 Type:  defect       |                   Status:  new
             Priority:  normal       |                Component:
              Version:  git-master   |  undetermined
             Keywords:  mpegts       |               Resolution:
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  0

Comment (by hungnv):

 Of course, the transcode command line destroys the timestamps, and that is
 probably the cause of the error; -copyts should help; hopefully, the old
 bugs of the TS muxer with timestamps will not be a problem here.

 I just tried -copyts.
 Input video:
   Duration: 00:00:06.02, start: 0.058667, bitrate: 1234 kb/s

 Output video:
 Duration: 00:00:06.03, start: 1.448644, bitrate: 1099 kb/s

 It's still a little bit different.

 I will try to implement -copyts into test app to see if problem can be
 solved or not.


Ticket URL: <https://trac.ffmpeg.org/ticket/4037#comment:19>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list