[FFmpeg-trac] #5850(avdevice:open): Using Hauppauge HD-PVR fails (streaming I/O)

FFmpeg trac at avcodec.org
Wed Nov 16 17:28:34 EET 2016

#5850: Using Hauppauge HD-PVR fails (streaming I/O)
             Reporter:  naums       |                    Owner:
                 Type:  defect      |                   Status:  open
             Priority:  normal      |                Component:  avdevice
              Version:  git-master  |               Resolution:
             Keywords:  v4l2        |               Blocked By:
             Blocking:              |  Reproduced by developer:  0
Analyzed by developer:  0           |

Comment (by naums):


 I've done some more testing (with avplay and open broadcast software
 (OBS)). I've tried building avconv 12 myself and tested it with the HD
 PVR: Segmentation fault on

 ./avplay /dev/video0

 I've built avplay 11.8 and it works fine (opens the device correctly and
 plays the video-stream correctly. Does not stop after some seconds. Call
 like above.

 So I went into it and built shared libaries and changes the version
 numbers of libavdevice, libavcodec and libavformat to 57 (like the ffmpeg-
 ones in my computer), and libavutil to 55. Then ran configure and make

 ./configure --enable-shared

 So I got libavdevice.so.57 and the other files. Told my system to look for
 the libs in this directory (after moving the files into the root-folder)

 export LD_LIBRARY_PATH=$(pwd)

 and ran OBS -> crashed, could not initiate some audio-buffers. Okay.
 Deleted every avconv-Shared Object file except for libavdevice.so.57 and
 it works quite fine. Opening the HD PVR in OBS works fine now.

 On a side note: using the device with ffplay also works fine, when opening

 # this works fine
 ffplay /dev/video0

 # this does not work (same error as above)
 ffplay file://dev/video0

 I guess ffplay (and therefore the current ffmpeg-libav) considers the HD
 PVR-file as regular file, not as streamable(?). Patching the libavdevice
 with the one from avconv 11.8 apparently fixes this behaviour and lets
 ffplay use the device as a video-stream.

 I hope that helps in any way to fix the bug.

 Kind regards

Ticket URL: <https://trac.ffmpeg.org/ticket/5850#comment:9>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list