[FFmpeg-trac] #5882(ffmpeg:new): Certain x264 videos do not play on Apple decoders (Quicktime/iTunes/iPad)

FFmpeg trac at avcodec.org
Sun Oct 9 00:01:52 EEST 2016

#5882: Certain x264 videos do not play on Apple decoders (Quicktime/iTunes/iPad)
             Reporter:  Technologov  |                     Type:  defect
               Status:  new          |                 Priority:  critical
            Component:  ffmpeg       |                  Version:  git-
             Keywords:  Apple        |  master
  QuickTime iTunes iPad              |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 Summary of the bug:
 Certain x264 encoded videos do not play on Apple decoders

 They can forward/rewind/seek first few minutes of the video, and after a
 certain point I can't forward/rewind/seek video (but seeking audio still
 works), and video stops playing after reaching that point. (usually after
 2-3 minutes near the beginning)

 To reproduce: Encode any problematic video with libx264 and try to play it
 with QuickTime on Windows.

 This problem happens with ALL Apple decoders (iTunes+Quicktime on
 Windows 7, Quicktime on Mac, and my Apple iOS Video Player on iPad Pro).

 The problem on two problematic videos is instantly visible with
 Quicktime on Windows:I get
 "Error -2002: a bad public movie atom was found in the movie"

 So far I was able to find 3 such videos out of a my personal collection of
 700+ videos, so we speak at under 0.5% chance of hitting this super-
 critical bug.

 The resulting video files can be played and seeked just fine using VLC or
 Windows Media Player. Still the problem of such severity should be

 How to reproduce:
 $ ffmpeg -i $INPUT_Problematic-Source.y4m -b:v 1000k -pix_fmt yuv420p

 NOTE: Using any other bitrate also triggers this bug; no effect. Using
 resolution scaling (like -s 640x360) also triggers this bug; no effect.
 Only if the source is "problematic".

 ffmpeg version N-81947-gc45ba26-1 Copyright (c) 2000-2016 the FFmpeg
 built with gcc 6.1.1 (Debian 6.1.1-11) 20160802

 (also tried ffmpeg version 3.1.2-1 which comes with Debian Linux
 9/testing; same results)

 Platform: Debian 9/testing/x64

 FFmpeg's encoder output:

 Here is an example broken video file: -- (video data was blurred on

 I have no clue what's Apple decoder doesn't like. Is it the MPEG4-AVC
 video stream or MP4 containers that ffmpeg produces?

 One thing I know for sure, Audio is not related. Even if I remove audio
 completely and encode only video (using -map 0:0 option from *.mkv source)
 I still get into this bug.

 -Technologov, 08.10.2016.

Ticket URL: <https://trac.ffmpeg.org/ticket/5882>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list