[FFmpeg-trac] #5817(build system:new): compilation guide does not work with latest version

FFmpeg trac at avcodec.org
Fri Sep 2 11:37:14 EEST 2016

#5817: compilation guide does not work with latest version
             Reporter:               |                     Type:  defect
  marcelo.emmerich                   |                 Priority:  normal
               Status:  new          |                  Version:
            Component:  build        |               Blocked By:
  system                             |  Reproduced by developer:  0
             Keywords:  compilation  |
  guide msvc visual studio           |
             Blocking:               |
Analyzed by developer:  0            |
 Followed strictly the compilation guide from
 for Windows 10 x64 with VS 2015 and FFMPEG 3.1.3.

 When doing "make" the following error appears:

 C:/ffmpeg/libavcodec/nvenc.c(173): error C4013: "LoadLibrary" undefined;

 make: *** [/c/ffmpeg/common.mak:60: libavcodec/nvenc.o] Error 2

 I tried the older releases of FFMPEG and they all worked fine, but it
 didnĀ“t work for the newest version, neither on Windows 10 nor on Windows

 How to reproduce:
 Get VS 2015, set up MSYS2, yasm and gas-preprocessor as described in the
 guide. (Veryfying my FFMPEG setup worked correctly.)
 Set up the variables in VS2015 x86 x64 Cross Tools Command Prompt like
 they do in the guide,open the msys2 shell, configure and make.

Ticket URL: <https://trac.ffmpeg.org/ticket/5817>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list