[FFmpeg-trac] #7654(avcodec:closed): hevc_amf does not honor -level option

FFmpeg trac at avcodec.org
Sun Jul 5 18:55:04 EEST 2020

#7654: hevc_amf does not honor -level option
             Reporter:  Tupsi       |                    Owner:
                 Type:  defect      |                   Status:  closed
             Priority:  minor       |                Component:  avcodec
              Version:  git-master  |               Resolution:  fixed
             Keywords:  amf         |               Blocked By:
             Blocking:              |  Reproduced by developer:  0
Analyzed by developer:  0           |
Changes (by Tupsi):

 * status:  reopened => closed
 * resolution:   => fixed


 Replying to [comment:13 cus]:
 > The command line is wrong.
 > -level 5.0 should be used, not -level 50.
 > Closing as invalid.

 You did not take the time to read my whole ticket, because then you would
 have seen, that I also tried 5.0 and not only the 50 mentioned in the
 commandline example.

 Doesnt matter, as I just downloaded a half current version from zeranoe
 (git from 20200628) and can clarify, that it is indead NOW working as
 intended, meaning, if you you use -level 5.1 you get Main at L5.1 and not the
 highest possible as it was before.

 So whoever changed that to the better, THANK YOU for understanding the
 ticket and fixing it :-)

 I just even tried -level 156 which according to the help should get me
 Main at L5.2 and it did! So both options work now, entering the human version
 as well as the machine version.

 So I would suggest to close the ticket.

Ticket URL: <https://trac.ffmpeg.org/ticket/7654#comment:17>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list