[FFmpeg-trac] #8542(undetermined:reopened): ffmpeg use kmsgrab on wayland not working

FFmpeg trac at avcodec.org
Thu May 7 20:52:01 EEST 2020

#8542: ffmpeg use kmsgrab on wayland not working
             Reporter:               |                    Owner:
  chenjie199234                      |
                 Type:  defect       |                   Status:  reopened
             Priority:  normal       |                Component:
                                     |  undetermined
              Version:  git-master   |               Resolution:
             Keywords:  kmsgrab      |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |

Comment (by maximbaz):

 To add some (hopefully helpful) details:

 - sway maintainers mentioned that the root cause of the issue is that
 ffmpeg doesnt support modifiers [1]
 - just like discussed here [2], Intel GPUs use I915_FORMAT_MOD_Y_TILED_CCS
 modifier (0x100000000000004), which uses two planes: compressed texture +
 color surface
 - I confirm that my GPU uses exactly the same I915_FORMAT_MOD_Y_TILED_CCS
 - I saw that kmsgrab supports {{{ -format_modifier }}} flag, but whether I
 use {{{ -format_modifier 0x100000000000004 }}} or {{{ -format_modifier
 72057594037927940 }}} (decimal value) I still get the same error.
     - ffmpeg contains this in the verbose log: {{{ Reading option
 '-format_modifier' ... matched as AVOption 'format_modifier' with argument
 '0x100000000000004'. }}}

 Could it be just a misconfiguration on our side? Or a missing support for
 this specific DRM modifier?

 1: https://github.com/swaywm/sway/issues/4961#issuecomment-579903298
 2: https://github.com/swaywm/wlroots/issues/1965#issuecomment-597619178

Ticket URL: <https://trac.ffmpeg.org/ticket/8542#comment:5>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list