[FFmpeg-trac] #7717(ffmpeg:new): -disposition is broken for mka containers

FFmpeg trac at avcodec.org
Fri Feb 12 17:33:39 EET 2021

#7717: -disposition is broken for mka containers
             Reporter:  hicksel      |                    Owner:
                 Type:  defect       |                   Status:  new
             Priority:  normal       |                Component:  ffmpeg
              Version:  git-master   |               Resolution:
             Keywords:               |               Blocked By:
  disposition,mka                    |
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |

Comment (by droid-xx):

 I haven't tried an .mka file, but I can set or remove disposition tags in
 .mkv files just fine. I think the problem lies with .flac files, in your
 case you're remuxing into .flac while trying to set the disposition flag.

 But apparently setting disposition flags for streams inside .flac files
 doesn't work. I just tried setting various flags but it doesn't work
 (disposition settings are ignored in the output file).

 Example command used:

 ffmpeg -i input.mkv -map 0 -c copy -disposition:a:0 dub output.flac

Ticket URL: <https://trac.ffmpeg.org/ticket/7717#comment:2>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list