[FFmpeg-trac] #9184(avfilter:open): pngdec output frame that has double image

FFmpeg trac at avcodec.org
Mon Jul 26 08:31:36 EEST 2021


#9184: pngdec output frame that has double image
-------------------------------------+-------------------------------------
             Reporter:  akoryagin    |                    Owner:  (none)
                 Type:  defect       |                   Status:  open
             Priority:  important    |                Component:  avfilter
              Version:  unspecified  |               Resolution:
             Keywords:  artefact on  |               Blocked By:
  the video                          |
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
-------------------------------------+-------------------------------------
Comment (by wenbin,chen):

 {{{
 ffmpeg -init_hw_device vaapi=va -filter_hw_device va -hwaccel vaapi
 -hwaccel_output_format vaapi -i 1080P_THE_HOBIT3_1920x1080_2700frames.264
 -filter_complex
 "movie=alogo.png:loop=100,setpts=N/FRAME_RATE/TB[mv];[mv]hwupload=extra_hw_frames=10,format=vaapi[watermark];
 [0:v]scale_vaapi=w=1280:h=720[temp1];[temp1][watermark]overlay_vaapi=x=1180:y=355:alpha=1"
 -c:v h264_vaapi -b:v 3M -maxrate 3M -c:a copy -y -movflags +faststart
 output.mp4
 }}}

 Hi Pljushevij. Here is the command for vaapi. There is no "shortest"
 option so you need to set "loop" for movie. And overlay_vaapi seems
 doesn't process alpha channel, so you need to set "alpha" option for
 overlay_vaapi. And somehow the command cannot work on "sailboat.ts" but
 can work on other video. Please use qsv as vaapi only have limited
 function.
-- 
Ticket URL: <https://trac.ffmpeg.org/ticket/9184#comment:19>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker


More information about the FFmpeg-trac mailing list