[FFmpeg-trac] #9215(ffmpeg:new): stream_loop -1 not working with filter_complex overlay

FFmpeg trac at avcodec.org
Wed May 5 00:34:52 EEST 2021

#9215: stream_loop -1 not working with filter_complex overlay
             Reporter:  codeSam      |                     Type:  defect
               Status:  new          |                 Priority:  important
            Component:  ffmpeg       |                  Version:
                                     |  unspecified
             Keywords:  stream_loop  |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 Summary of the bug:

 Stream does not start when using stream_loop -1 together with
 filter_complex overlay. With stream_loop 0 stream is ok, but of course
 doesn't update the overlay.

 How to reproduce:
     '-thread_queue_size', '1024',
     '-i', 'rtsp://...',
     '-f', 'image2',
     '-stream_loop', '-1',
     '-i', 'picture.png',
     '-filter_complex', 'overlay=(main_w-
     '-ar', '44100',
     '-ab', '128k',
     '-f', 'flv',
     '-g', '30',
     '-vcodec', 'libx264',
     '-preset', 'ultrafast',
     '-crf', '30',

 In single line:

 ffmpeg -thread_queue_size 1024 -i rtsp://... -f image2 -stream_loop -1 -i
 picture.png -filter_complex "overlay=(main_w-
 overlay_w)/2:main_h*0.1-overlay_h" -acodec aac -ar 44100 -ab 128k -f flv
 -g 30 -vcodec libx264 -preset ultrafast -crf 30 rtmp://...

 ffmpeg version 4.4 is the problem. Works fine on FFmpeg 4.3.2. Also tried
 loop instead of stream_loop. Same result.
Ticket URL: <https://trac.ffmpeg.org/ticket/9215>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list