[FFmpeg-user] DXVA2 problems since ffmpeg v0.9.1

Bjoern Drabeck bjoern.drabeck at gmail.com
Tue Feb 7 10:46:18 CET 2012

Hi Carl,

thanks for your reply, I am sure the problem happened between 0.9 and
0.9.1, so hopefully it shouldn't be too hard to track it down... so will
have a look tmw. Basically it doesn't seem to accept overriding
the codec->get_format function and the same for the hwaccel_context, which
always gets reset to 0.

If I find some time, maybe I can later provide you with a simple demo
program, which you (or whoever on your team) can use for testing to see if
it still works..


Bjoern Drabeck <bjoern.drabeck <at> gmail.com> writes:
> > I have been playing around with using dxva2 for decoding h264 movies,
> which
> > worked fine so far (ie up to version 0.9)
> >
> > However, for every newer version since then (FYI: I am using the zeranoe
> > builds btw) it never calls into my custom get format function
> > (codec->get_format), and the hwaccel and hwaccel_context members are
> still
> > always 0 [all of this worked fine in previous versions]
> Could you try git bisect to find the change introducing the problem?
> Unfortunately, no developer actively uses Windows and I suspect you
> will not provide the necessary sources to test, or will you?
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list