[FFmpeg-user] error w configure ffmpeg

Jim Shupert jshupert at pps-inc.com
Wed Feb 8 15:12:35 CET 2012

>> if i look in my usr/lib
>> i see a libx264.so.85
so - i need a newer x264 -- likely this is what is errant w my libvpx as well

here is how i am obtaining these

------------------- obtain / Install x264

git clone git://git.videolan.org/x264
cd x264
./configure --enable-static
sudo checkinstall --pkgname=x264 --default --pkgversion="3:$(./version.sh | \
     awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes

-------------- obtain / Install libvpx

git clonehttp://git.chromium.org/webm/libvpx.git
cd libvpx
sudo checkinstall --pkgname=libvpx --pkgversion="$(date +%Y%m%d%H%M)-git"
--backup=no \
     --default --deldoc=yes

maybe a better means would be to obtain snapshots of each

thank you carl ... i was thinking it might have been something like
- enable_static in the configure command

but it is rather my use of an 'old' x264 ( and maybe libvpx )

how do you obtain the newest of these?

thanks again.

More information about the ffmpeg-user mailing list