[FFmpeg-user] Confused about libx264.

bat guano batguano999 at hotmail.com
Fri Feb 17 22:45:44 CET 2012

I have FFmpeg compiled with libx264 running on Ubuntu..

ffmpeg version N-37710-g29034e6 Copyright (c) 2000-2012 the FFmpeg developers
  built on Feb 10 2012 07:28:14 with gcc 4.5.2
  configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --disable-encoder=vorbis --enable-libvo-amrwbenc --enable-libvo-aacenc --enable-libspeex

x264 works ok using commands like this:-
ffmpeg -i foo -vcodec libx264 -acodec libfaac foo.mp4
No problem. :-)

But when I use command "ffmpeg -codecs" it shows:-
   V    libx264         libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10

Why does it not show "E" to signify "Encoding supported"?


More information about the ffmpeg-user mailing list