[FFmpeg-user] ffmpeg on low power hardware

funtastic officemab at gmail.com
Wed Feb 22 21:35:16 CET 2012

Am 22. Februar 2012 05:49 schrieb John Saturday <stozher at gmail.com>:

> ffmpeg -vsync 2 -async 1 ...
> See this options... and also if concatenate some mpeg.ts in next time
> use "ffmpeg -isync ..." to rebuild index in output file.
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

thank you! This is the first time I get reasonable frame rates while
downloading the rtsp stream on my embedded device! thank you so far....

Nevertheless I have an error again.... and the output file seems to be
corrupted... I tried with several combinations but all of them failed....
one of my experiments: (I tried with the -f mpegts options too... but that
didn't show an improvement)

The last one I tried:
ffmpeg -y -i rtsp://mystream.mp4 -f h264 -vcodec copy -acodec copy -scodec
copy -vsync 2 -async 1 stream.mp4

For better understanding: I use the following URL as rtsp stream:

One of the errors:
"Application provided invalid, non monotonically increasing dts to muxer in
stream 0: 7200 >= 7200"
--> the error happens at the beginning - the output file cannot be read...

I think the solution for this problem is pretty close... but I don't know
how to get a working final result...
Can someone provide some (hopefully) final hints?

More information about the ffmpeg-user mailing list