[FFmpeg-user] ffmpeg on low power hardware

funtastic officemab at gmail.com
Thu Feb 23 00:59:43 CET 2012

Am 22. Februar 2012 22:40 schrieb John Saturday <stozher at gmail.com>:

> > http://pastebin.com/QHeUuVUx
> ffmpeg -vsync 2 -async 1 -i "rtsp://.../video.mp4" -f matroska -c:v
> rawvideo -c:a pcm_s16le "TV $(date --utc +'%F %T').mkv" -f matroska
> -c:v rawvideo -c:a pcm_s16le - | ffplay -f matroska -i -
> Press Q or close FFPLAY window to stop record...
> Good luck!
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

thanks.... this works on my powerful desktop machine... BUT why changing to
matroska format??? On my embedded system where I would like to keep
encoding/decoding to a minimum this totally fails.... I get the same bad
frame rate of 2-4 fps.... as before

I tried to use "-f mp4" instead of "-f matroska" but that
produced a broken output file... (but a good framerate)

So the only thing I would like to achive is a simple rtsp dump of the
stream from here:
a "stream.mp4" file located on my system... without decoding/encoding
into different formats.

Everything I tried ended in errors (e.g. "Application provided invalid, non
monotonically increasing dts to muxer") or with a horrible framerate on my
embedded system (and broken output files.)

Any ideas? It should really be as simple as possible in order to get a
reasonable frame rate on low power hardware....

More information about the ffmpeg-user mailing list